Und es geht doch!! – Teil 1

Der letzte Beitrag liegt etwas zurück, was unserem familiären Nachwuchs geschuldet ist. Mit diesem Beitrag schreibe ich wieder mal etwas zum Thema „Den eigenen Computer einrichten und verändern leicht gemacht“. Meine letzte Umrüstung war nämlich ein ganz schöner Kampf. Und erforderte viel Recherchearbeit. Aber es hat sich gelohnt: Ich konnte nachträglich RAID in Windows 7 installieren. Doch der Reihe nach:

Die Situation war typisch: Ich bin auf ein neues Board umgestiegen (nebst CPU), bei Intel und ASUS verblieben (H87-Pro), da ich diese Boards schon kenne und auch gute Erfahrungen damit habe. Also Tausch des Mainboards und Installation von Windows 7. Das lief alles problemlos und zunächst war ich auch mit dem neuen System zufrieden. Besondere Features probiere ich erst im Laufe der Zeit aus, also wenn das Grundsystem läuft. Denn dieses ist für mich immer auch ein Produktivsystem. Gewundert hatte ich mich allerdings, dass sich der Intel Rapid Start Treiber1 nie installieren ließ. Die Fehlermeldung war relativ nichtssagend: Das System erfüllt nicht die Voraussetzungen einer Installation. Die erste Recherche war fällig und siehe da: Diese Funktion, sowie auch ein Teil der Intel Rapid Storage Funktionalität funktioniert nur, wenn das Board auf RAID, nicht auf AHCI läuft. Das ist an sich problemlos und muss man nur im BIOS einstellen. Allerdings sollte man das vor der Installation von Windows tun. Denn, so hieß es in allen Foren und Diskussionsbeiträgen: Das lässt sich nachträglich nicht machen bzw. nicht mehr ohne Neuinstallation ändern.

Die Aussage gründete darauf, dass Microsoft das ursprünglich nie vorgesehen habe und die Hersteller ein solches Vorgehen deshalb auch nicht unterstützen. Allerdings bekam ich dann mit, dass zumindest Gigabyte ein Tool anbietet, dass die nachträgliche Installation des RAID Treibers ermöglicht. Ich hatte es sogar in meinem Fall ausprobiert. Aber das konnte natürlich nicht klappen: War ja für Gigabyte Boards gedacht. Nun kontaktierte ich den Support von ASUS. Die Antwort lautete: Installieren sie neu, ASUS unterstützt das nicht und hat auch kein Tool dafür.((Der Hinweis auf den Hotfix wurde lapidar damit beantwortet, dass der Support auch dies nicht offiziell unterstützt. Da steht man dann schon blöd da.)) Da war ich dann doch fast am verzweifeln, denn ich hatte ja gerade frisch installiert und auch alle Programme aktiviert (was dann immer systematisch fällig ist). Das geht zwar dank SSD als Systemplatte leidlich fix. Aber all die Updates und eben Aktivierungen nehmen doch einige Zeit in Anspruch. Nicht zu vergessen die jeweiligen Einstellungen in den Programmen. Ich machte mich also noch einmal auf die Suche und über drei Querverweise kam ich schließlich darauf, dass es doch eine Lösung gibt.

Und die kommt von Microsoft selbst. Seit Vista scheint es einen Hotfix zu geben, der die nachträgliche Installation eines RAID Treibers (und wohl auch umgekehrt) erlaubt. Bei Microsoft firmiert das unter einer Hilfestellung zu einer Fehlermeldung. Die man eher nicht zu lesen bekommt, weil Windows beim Startversuch nach einer Umstellung im BIOS mit Bluescreen abstürzt. Aber der Inhalt der Beschreibung trifft das, um was es mir ging. Also lud ich den Hofix herunter, installierte ihn – und es funktioniert(e). Windows startet, braucht ein wenig länger, bis alles wirklich installiert ist, und benötigt einen zweiten Restart. Dann aber steht der Intel RAID Controller im Gerätemanager zur Verfügung. Und hier ist der Hofix zu finden.

Intel Raid Controller im Gerätemanager

Screenshot des Intel Raid Controller im Gerätemanager von Windows 7.

Aber Achtung!!: Ich hatte dann das Problem, dass der vorher bereits installierte Intel Rapid Storage Treiber beschädigt war. Das kann man ganz leicht herausfinden, indem man die Software aufruft und entweder eine Fehlermeldung erhält, oder eben nicht. Geäußert hat sich das bei mir so, dass ich dachte, mir sei meine 3 TB Festplatte „abgeschmiert“. Irgendwie waren die Partitionen zwar noch angezeigt, aber Windows hatte keinen Zugriff darauf. Was zu ewigen Startzeiten von Windows führte, weil es immer den Versuch gab, sie einzubinden. Hier kann ich nicht sagen, was die Ursache war. Ich vermute, es war die darauf installierte Reserve(boot)partition. Ich gehe also eher nicht davon aus, dass das allgemein mit dem Hotfix passiert. Der Versuch, die darauf befindlichen Daten mittels Recovery wieder herzustellen, scheiterte deshalb, weil die Einbindung immer noch nicht klappte. Erst nach einer erneuten Installation des Rapid Storage Programms lief wieder alles einwandfrei. Das hätte ich wahrscheinlich gleich machen sollen, dann wären die Daten nicht futsch gewesen. Glücklicherweise war meine eigentliche Datenpartition bzw. Festplatte davon nicht betroffen. Und außerdem habe ich ein gutes Datensicherungskonzept. Jetzt werde ich dann mal das Rapid Start Programm installieren und in Ruhe ausprobieren. Das wird der Bericht im zweiten Teil sein.

Lessons Learned: Hartnäckigkeit lohnt sich. Vor allem schaue ich jetzt genauer darauf, wann die jeweiligen Informationen in die Boards und Foren gepostet wurden. Es war ein ziemlich versteckter Hinweis auf den Hotfix, der ruhig weiter verbreitet werden kann. Und ein Letztes: Auch der Support weiß viele Dinge nicht. Und ein Letztes: So manche Beiträge in den Foren sind schon arg „besserwisserisch“. Vor allem, wenn es um Fragen nach RAID Konfigurationen geht.

  1. Hier gibt es die offizielle Anweisung von Intel http://download.intel.com/support/motherboards/desktop/sb/rapid_start_technology_user_guide.pdf []
PDF24    Sende Artikel als PDF   

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.